A status update was posted for the EU region on 8/13/25. Upon further investigation, we confirmed that the issue was isolated to the US region and did not affect EU services. We regret the incorrect status update and have adjusted our monitoring and communication process to ensure updates are more region-specific moving forward.
Posted Aug 19, 2025 - 16:36 UTC
Resolved
CXone Mpower Expert - Service Disruption Resolved - All Services Running Normally. The CXone Mpower Expert Engineering team has deployed a fix and monitored the deployment to make sure sites are stable. The issue is now resolved at this time. Event duration (19 mins)
Posted Aug 13, 2025 - 15:12 UTC
Monitoring
CXone Mpower Expert - Fix Deployed - All Services Running Normally. The CXone Mpower Expert Engineering team has deployed a fix and all services are running normally. We are currently monitoring sites for deployment stability. Event duration (19 mins)
Posted Aug 13, 2025 - 14:55 UTC
Investigating
CXone Mpower Expert Service Degradation: Sites unavailable. The CXone Mpower Expert Engineering team is investigating reports of site unavailability.
Posted Aug 13, 2025 - 14:44 UTC
This incident affected: Application (General Service), Search, Generative Search, In-Product Contextual Help, Email Services, Success Center, Analytics, and Geo-blocking.